VISIT AND LIKE OUR PAGE ON FACEBOOK
TAKE A LOOK AT OUR TWEETS ON TWITTER
SUBSCRIBE TO THE JOOMFREAK RSS FEED
VISIT OUR CHANNEL ON YOUTUBE

Account Details

Change your name, email, password or permanently delete your account. Change settings

We offer several ways you can get support from our experts: Support ForumKnowledgebaseNewsletter

Your Forum Posts

No posts to display.

Welcome, Guest
Username Password: Remember me
  • Page:
  • 1

TOPIC: Lightbox doesnt work

Lightbox doesnt work 20 Sep 2016 17:39 #9460

Hi!
First of all, thanks for the great template. Love it

I am just about to configure everything. And most of ait works as described in the manual!

But i cant solve a problem with the Lightbox. After clicking the Image it just diesplays the image on a new layer but not in this nice Lightbox like in your demo. On my page it doesnt get the Div class= sbox (i assume its squeezebox?).

Do you have an idea what i am doing wrong ( I already enabled & disabled jquery loading from the k2 configuration) Do I need another Plugin for it? Is this more an K2 Issue?

To understand my problem have a look at this URL and click header Image:
bridgeners-kosmos.de/index.php/fotografi...m/1-ein-k2-test-foto

Thanks for help!

Best
Mark
Last Edit: 20 Sep 2016 17:47 by mbridgener.

  • Posts:6
  • mbridgener
  • Fresh Boarder
  • OFFLINE
  • Karma: 0

Re: Lightbox doesnt work 21 Sep 2016 09:14 #9464

Hi,

i now managed it to open the nice modal using the modal.css (sbox) by adding following line into the index.php <?php JHTML::_('behavior.modal'); ?> but it still opens the ugly modal in the background So the Image opens twice. Does anybody know how to fix this?
Something is still using the class= modal..

Thanks for your help!

Best,
Mark

  • Posts:6
  • mbridgener
  • Fresh Boarder
  • OFFLINE
  • Karma: 0

Re: Lightbox doesnt work 22 Sep 2016 02:43 #9468

I think it happens because you installed jquery.magnific-popup plugin.

joomfreak

  • Posts:2819
  • isupport
  • Moderator
  • OFFLINE
  • Karma: 0

Re: Lightbox doesnt work 22 Sep 2016 12:03 #9472

Hi,

the magnific-popup plugin comes with k2, unfortunately. And it cannot be deactivated by configuration settings. I just restyled the pop-up CSS. Now it looks better.

  • Posts:6
  • mbridgener
  • Fresh Boarder
  • OFFLINE
  • Karma: 0
  • Page:
  • 1
Time to create page: 0.85 seconds
Tuesday 15 October 2019

joomfreak is not affiliated with or endorsed by the Joomla Project or Open Source Matters.
The Joomla logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.